Plugin authors are encouraged to read the 5.0.1 developer notes for information on backwards-compatibility.
WordPress versions 5.0 and earlier are affected by the following bugs, which are fixed in version 5.0.1. Updated versions of WordPress 4.9 and older releases are also available, for users who have not yet updated to 5.0.
- Karim El Ouerghemmi discovered that authors could alter meta data to delete files that they weren’t authorized to.
- Simon Scannell of RIPS Technologies discovered that authors could create posts of unauthorized post types with specially crafted input.
- Sam Thomas discovered that contributors could craft meta data in a way that resulted in PHP object injection.
- Tim Coen discovered that contributors could edit new comments from higher-privileged users, potentially leading to a cross-site scripting vulnerability.
- Tim Coen also discovered that specially crafted URL inputs could lead to a cross-site scripting vulnerability in some circumstances. WordPress itself was not affected, but plugins could be in some situations.
- Team Yoast discovered that the user activation screen could be indexed by search engines in some uncommon configurations, leading to exposure of email addresses, and in some rare cases, default generated passwords.
- Tim Coen and Slavco discovered that authors on Apache-hosted sites could upload specifically crafted files that bypass MIME verification, leading to a cross-site scripting vulnerability.
Thank you to all of the reporters for privately disclosing the vulnerabilities, which gave us time to fix them before WordPress sites could be attacked.
Download WordPress 5.0.1, or venture over to
Dashboard → Updates and click
Update Now. Sites that support automatic background updates are already beginning to update automatically.